Вход на сайт

Регистрация на сайте автоматическая при оформлении первого заказа

Модуль Умный фильтр товаров для Opencart 2.x - один из самых популярных и обязательных модулей для второй версии OC.

Фильтр товаров по цене, категориям, производителям, наличии, опциям и атрибутам, стандартным фильтрам.

Это расширенный фильтр товаров для Opencart 2, который поможет улучшить функциональность вашего интернет-магазина.

Работает по ajax. Имеет множество настроек. Можно адаптировать фильтр под ваш шаблон прописав css-селекторы блоков с товарами и постраничной навигацией.
Можно создать сколько угодно разных фильтров и выводить их в разные позиции сайта.

Модуль полностью на русском языке!

Установка модуля:
1. Распаковать скачанный архив
2. Загрузить выбранную версию модуля через админку
3. Обновить модификации
4. Перейти в Модули, установить модуль Умный фильтр товаров
5. Редактировать модуль, настроить, добавить модуль для вывода на сайте - вкладки Модули
6. Вывести модуль на страницах сайта через раздел Дизайн > Макеты

Лог изменений:
12.02.2019 - решены проблемы с перекрытием стилей некоторых шаблонов.

  • Opencart 2.0
  • Opencart 2.1 и ocStore 2.1
  • Opencart 2.2
  • Opencart 2.3 и ocStore 2.3

Нужен этот модуль для Opencart 3.0 ?

1. Скачайте и установите фикс Localcopy
2. Обновите модификации в админке
3. Загрузите модуль наново

Ошибка 500 после установки модуля означает, что случилась какая-то критическая ошибка в php.

Для определение проблемы можно:
1. Открыть файл logs/error.log на вашем сервере. В конце этого файла будут все последние критические ошибки.
2. Открыть в админке Инструменты > Логи ошибок - в этом месте отображаются ошибки, но не всегда.
3. Включить вывод ошибок php на экран - добавить следующий код в конец файла .htaccess:

php_value display_errors 1
php_value display_startup_errors 1
php_value error_reporting E_ALL

Возможные причины:

1. Если вы раньше не загружали модули в архиве через админку - вам нужно установить бесплатную модификацию localcopy.ocmod.xml согласно инструкции и после этого переустановить модуль

2. Возможно  в устанавливаемого модуля нет собственной страницы настроек и соответственно его не будет в списке Модулей

Два варианта решения:

1. Если при установке модуля из админки вылетает эта ошибка - вам нужно установить бесплатную FTP QuickFix модификацию localcopy.ocmod.xml. Она установиться без проблем через тот же установщик дополнений, только после установки не забудьте обновить модификации и затем можете приступать к установке любых модулей на Opencart 2.

2. Также решить эту ошибку можно по другому: прописать доступы к FTP в админке Система > Настройки > Магазин > вкладка FTP.

Если вы видите сообщение "Доступ запрещен!  У Вас нет прав для доступа к этой странице. Если она Вам нужна, обратитесь к администратору." -  нужно дать права администраторам на управление модулем или страницей.

Решение: в админке Opencart 2 переходим в Система > Пользователи > Группы пользователей > Администраторы и здесь нажимаем "Выделить все" ниже обоих блоков, затем Сохранить.

Еще одной причиной появления этой ошибки может быть не правильная установка модуля - файлы не загрузились на свои места. Загрузите файлы модуля вручную на сервер или установите фикс localcopy и переустановите модуль.

Решение: в админке Opencart 2 переходим в Система > Пользователи > Группы пользователей > Администраторы и здесь нажимаем "Выделить все" ниже обоих блоков, затем Сохранить.

Если модуль - это один XML файл,  то его расширение должно быть .ocmod.xml

Если модуль - это ocmod.zip архив, то его не нужно распаковывать, а устанавливать как есть. В таком архиве обязательно должна быть папка upload (может быть пустой), а также могут быть файлы модификаций: install.xml, install.php, install.sql. Никаких других файлов в корне архива быть не должно.

Читайте подробнее как устанавливать модули в Opencart 2

Эта ошибка означает, что в загружаемом архиве отсутсвует папка upload. Даже если у модуля нет файлов, кроме модификаций - эта папка должна присутствовать в архиве модуля .ocmod.zip, тогда она должна оставаться пустой.

Эта ошибка означает, что вы пытаетесь установить модификатор, который уже установлен или, возможно, у какого-то вашего модуля такой же ID.

Для решения этой ошибки вам нужно перед установкой удалить старую версию модификации в разделе Модули > Модификации.

Если такого модуля у вас нет, но совпадает ID, тогда нужно поменять значение параметра <code> в устанавливаемом модификаторе XML, сделать этот параметр уникальным дописав несколько символов.

Эта ошибка означает, что вы пытаетесь установить слишком объемный xml-модификатор.

Количество символов в ocmod.xml файле не должно превышать 65535.

Для решения ошибки нужно разбить xml-файл модификации на несколько частей, главное - не забыть задавать каждой уникальное значение в <code>, можно добавлять к текущему значению цифры 1,2,3... как идентификаторы части.

Еще одним способом решения есть изменения типа в поля, где храняться модификации, в таблице 'oc_modification' базы данных. Нужно выполнить следующий SQL-запрос:
ALTER TABLE oc_modification CHANGE xml xml MEDIUMTEXT CHARACTER SET utf8 COLLATE utf8_general_ci NOT NULL ;

Похоже, вы установили на Opencart 2.3.x.x модуль для более старых версий этой системы, то есть не совместимый модуль. Нужно удалить все файлы этого модуля, иначе ошибка не исчезнет.

Для удаления файлов модулей из админкм в один клик можно использовать модуль 

Также данная ошибка может возникать, если скрипт обращается к несуществующей таблице в базе данных. То есть, таблица модуля не создалась при установке. Читайте инструкцию по установке и переустановите модуль.

Если модуль не реагирует на ваши действия, будь-то нажатие на кнопку или загрузка карты или выбор даты или на любое другое действие которое есть в функционале модуля - скорее всего произошел конфликт в JS-скриптах.

Нажмите F12 на проблемной странице в браузере - откроется панель вебмастера, где на вкладке Console можно увидеть конфликты в скриптах, если они есть. Данное действие доступно в браузерах Chrome, Opera, Firefox.


Это раздел отзывов, комментариев и вопросов!
Решением проблем занимается техподдержка

  • Цена: 299 руб.

- с помощьюВарианты оплаты заказа
или
Оформить VIP-подписку на все файлы
Подробнее о VIP-подписке

  • Cовместимость протестирована
  • Формат OCMOD
  • Открытый код
  • Нет привязки к домену
  • Нет вирусов и жучков
  • Быстрая техподдержка

Про Opencart 2:

Купить VIP подписку на модули и шаблоны Opencart 2.x

Смотрите также:

Модуль Отзывы о сайте на Opencart 2

Модуль Отзывы о сайте на Opencart 2

Модуль Отзывы о сайте на Opencart 2 -  это дополнение, которое позволит вашим покупателям остав..

Цена: 299 руб.

Модуль Просмотренные товары для Opencart 2

Модуль Просмотренные товары для Opencart 2

Модуль Просмотренные товары для Opencart 2 - выводит последние товары, которые смотрел покупатель. М..

Цена: 199 руб.

Модуль Поиск в позиции для Opencart 2.x

Модуль Поиск в позиции для Opencart 2.x

Модуль поиска по товарам для Opencart 2.x, форму можно вывести в позиции на сайте. Он ничем не отлич..

Цена: 199 руб.

Результаты поиска в модальном окне Opencart 2

Результаты поиска в модальном окне Opencart 2

Модуль Результаты поиска в модальном окне Opencart 2 - настраиваемый модуль с несколькими вариа..

Бесплатно

Форма авторизации в шапке на Opencart 2.x

Форма авторизации в шапке на Opencart 2.x

Простая модификация которая добавляет форму авторизации в шапку сайта на Opencart 2.x. Расширение бе..

Бесплатно

Модуль Стикеры на товары для Opencart 2

Модуль Стикеры на товары для Opencart 2

Модуль для прикрепления стикетов к товарам на Opencart 2. Стикеры - это бирки, ленты, штамы, звездоч..

Цена: 299 руб.

Модуль Стена подкатегорий для Opencart 2.x

Модуль Стена подкатегорий для Opencart 2.x

Модуль Стена подкатегорий для Opencart 2 - позволит вывести подкатегории  с картинками из ..

Цена: 199 руб.

Модуль Опросы и голосование на Opencart 2.x

Модуль Опросы и голосование на Opencart 2.x

Модуль для создания опросов или голосований в интернет-магазине на Opencart 2.x. Хотите спросит..

Цена: 249 руб.