Вход на сайт

Регистрация на сайте автоматическая при оформлении первого заказа

Модуль Кнопки Купить для опций Opencart 2.x

Модуль Кнопки Купить для каждой опции на странице категории и в карточке товара Opencart 2.x. Может быть полезным при продаже нескольких вариантов одного товара. Если в опций есть наценка или цена - она будет отображаться в списке товаров, откуда товар сразу можно будет добавить в корзину. В карточке товара также можно для каждой опции задавать количество товара перед добавлением в корзину.

Внимание!
- модуль работает только с опциями типа Radio.
- не нужно искать модуль с списке Модулей - его там нет,  у него нет настроек.
- модуль не работает с другими модулями, которые изменяют опции.

Установка модуля:

1. Распаковать архив c модулем для вашей версии Opencart
2. Загрузить содержимое папки upload на сервер
3. Установить две модификации ocmod.xml которые есть в архиве. Одна модификация для категории, другая для карточки товара - по названию можно определить.
4. Необязательно! Можно настроить размер картинок товаров в категории 90х120 для лучшего отображения.

  • Opencart 2.0
  • Opencart 2.1
  • Opencart 2.2
  • Opencart 2.3

Смотрите также модули для Opencart 3.0

Возможные причины:

1. Если вы раньше не загружали модули в архиве через админку - вам нужно установить бесплатную модификацию localcopy.ocmod.xml согласно инструкции и после этого переустановить модуль

2. Возможно  в устанавливаемого модуля нет собственной страницы настроек и соответственно его не будет в списке Модулей

Два варианта решения:

1. Если при установке модуля из админки вылетает эта ошибка - вам нужно установить бесплатную FTP QuickFix модификацию localcopy.ocmod.xml. Она установиться без проблем через тот же установщик дополнений, только после установки не забудьте обновить модификации и затем можете приступать к установке любых модулей на Opencart 2.

2. Также решить эту ошибку можно по другому: прописать доступы к FTP в админке Система > Настройки > Магазин > вкладка FTP.

Если вы видите сообщение "Доступ запрещен!  У Вас нет прав для доступа к этой странице. Если она Вам нужна, обратитесь к администратору." -  нужно дать права администраторам на управление модулем или страницей.

Решение: в админке Opencart 2 переходим в Система > Пользователи > Группы пользователей > Администраторы и здесь нажимаем "Выделить все" ниже обоих блоков, затем Сохранить.

Если модуль - это один XML файл,  то его расширение должно быть .ocmod.xml

Если модуль - это ocmod.zip архив, то его не нужно распаковывать, а устанавливать как есть. В таком архиве обязательно должна быть папка upload (может быть пустой), а также могут быть файлы модификаций: install.xml, install.php, install.sql. Никаких других файлов в корне архива быть не должно.

Читайте подробнее как устанавливать модули в Opencart 2

Эта ошибка означает, что в загружаемом архиве отсутсвует папка upload. Даже если у модуля нет файлов, кроме модификаций - эта папка должна присутствовать в архиве модуля .ocmod.zip, тогда она должна оставаться пустой.

Эта ошибка означает, что вы пытаетесь установить модификатор, который уже установлен или, возможно, у какого-то вашего модуля такой же ID.

Для решения этой ошибки вам нужно перед установкой удалить старую версию модификации в разделе Модули > Модификации.

Если такого модуля у вас нет, но совпадает ID, тогда нужно поменять значение параметра <code> в устанавливаемом модификаторе XML, сделать этот параметр уникальным дописав несколько символов.

Эта ошибка означает, что вы пытаетесь установить слишком объемный xml-модификатор.

Количество символов в ocmod.xml файле не должно превышать 65535.

Для решения ошибки нужно разбить xml-файл модификации на несколько частей, главное - не забыть задавать каждой уникальное значение в <code>, можно добавлять к текущему значению цифры 1,2,3... как идентификаторы части.

Еще одним способом решения есть изменения типа в поля, где храняться модификации, в таблице 'oc_modification' базы данных. Нужно выполнить следующий SQL-запрос:
ALTER TABLE oc_modification CHANGE xml xml MEDIUMTEXT CHARACTER SET utf8 COLLATE utf8_general_ci NOT NULL ;

Похоже, вы установили на Opencart 2.3.x.x модуль для более старых версий этой системы, то есть не совместимый модуль. Нужно удалить все файлы этого модуля, иначе ошибка не исчезнет.

Для удаления файлов модулей из админкм в один клик можно использовать модуль 

Также данная ошибка может возникать, если скрипт обращается к несуществующей таблице в базе данных. То есть, таблица модуля не создалась при установке. Читайте инструкцию по установке и переустановите модуль.

Если модуль не реагирует на ваши действия, будь-то нажатие на кнопку или загрузка карты или выбор даты или на любое другое действие которое есть в функционале модуля - скорее всего произошел конфликт в JS-скриптах.

Нажмите F12 на проблемной странице в браузере - откроется панель вебмастера, где на вкладке Console можно увидеть конфликты в скриптах, если они есть. Данное действие доступно в браузерах Chrome, Opera, Firefox.

Ошибка 500 после установки модуля означает, что случилась какая-то критическая ошибка в php.

Для определение проблемы можно:
1. Открыть файл logs/error.log на вашем сервере. В конце этого файла будут все последние критические ошибки.
2. Открыть в админке Инструменты > Логи ошибок - в этом месте отображаются ошибки, но не всегда.
3. Включить вывод ошибок php на экран - добавить следующий php-код в начало php-файла контроллера модуля внутри функции index(){...} :

ini_set('error_reporting', E_ALL);
ini_set('display_errors', 1);
ini_set('display_startup_errors', 1);

4. Включить вывод всех ошибок и предупреждений в файле .htaccess:

php_value display_errors 1
php_value display_startup_errors 1
php_value error_reporting E_ALL
Техподдержка предоставляется только для клиентов, купивших модуль.
Клиентам с "VIP-подпиской" - техподдержка не предоставляется!

Из-за большого количества псевдоклиентов - мы вынуждены ввести правила комментирования.

Правила обращения в техподдержку
Нужно указать:
1. Номер заказа
2. Сборка/версия Opencart
* Email заказа и клиента должны совпадать
* письма в техподдержку без этих данных будут удалятся!

  • Цена: 199 руб.

- с помощьюВарианты оплаты заказа
или
Оформить VIP-подписку на все файлы
Подробнее о VIP-подписке

  • Cовместимость протестирована
  • Формат OCMOD
  • Открытый код
  • Нет привязки к домену
  • Нет вирусов и жучков
  • Быстрая техподдержка

Про Opencart 2:

Купить VIP подписку на модули и шаблоны Opencart 2.x

Смотрите также:

Модуль Скидки для групп покупателей Opencart 2.x

Модуль Скидки для групп покупателей Opencart 2.x

Модуль Скидки для групп покупателей или Total Customer Group Discount для Opencart 2.x позволяет зад..

Цена: 249 руб.

Модуль Загрузка файлов к заказу для Opencart 2.3

Модуль Загрузка файлов к заказу для Opencart 2.3

Если при оформлении заказа клиент должен отправить вам файл - этот модуль то что вам нужно. Он предн..

Цена: 249 руб.

Модуль Корзина Popup для Opencart 2

Модуль Корзина Popup для Opencart 2

Модуль popup-корзины товаров на Opencart 2. Попап окно появляеться после добавления товара в корзину..

Цена: 249 руб.

Пропустить корзину в Opencart 2

Пропустить корзину в Opencart 2

Простое дополнение, которое позволит пропустить корзину в Opencart 2. При нажатии на корзину, е..

Бесплатно

Только по одному товару в корзине Opencart 2.x

Только по одному товару в корзине Opencart 2.x

Модуль позволяет добавлять в корзину только товары в количестве 1, то есть , по одному товару. Такое..

Цена: 199 руб.

Модуль Минимальная сумма заказа для Opencart 2.x

Модуль Минимальная сумма заказа для Opencart 2.x

Модуль для ограничения минимальной суммы для оформления заказа в Opencart 2.x. Такое дополнение може..

Цена: 199 руб.

Модуль Накопительные скидки OCMOD Opencart 2.x

Модуль Накопительные скидки OCMOD Opencart 2.x

Модуль Накопительные скидки OCMOD Opencart 2.0.0.0 - 2.3.x.x, - это по сути два модуля, которые..

Цена: 349 руб.

Модуль Запрос цены в Opencart 2

Модуль Запрос цены в Opencart 2

Модуль Запрос цены в Opencart 2 - удаляет цену на сайте и добавляет форму запроса цены. Клиент запра..

Цена: 199 руб.