Вход на сайт

Регистрация на сайте автоматическая при оформлении первого заказа

Модуль Баннер Плюс позволит создавать мультиязычные баннеры в Opencart 2, то есть разные банеры для разных языков. По умолчанию в Баннерах многоязычными являются только заголовки, но с помощью модуля "Баннер +" мультиязычными будут все поля баннера: заголовок, ссылка и картинка. Таким образом можно создавать одинаковые баннеры на разных языках или вообще разные баннеры в зависимости от выбраного языка.

Установка модуля:
1. Распаковать архив и выбрать модуль для вашей версии Opencart
2. Установить модуль через админку (banner_plus.ocmod.zip) или распаковать и загрузить файлы на сервер (модуль заменяет стандартные файлы баннера)
3. Обновить модификации в админке (не обязательно, но рекомендуеться)
4. Перейти в (Система) > Дизайн > Баннеры для создания мультиязычного баннера

Модуль совместим с Opencart 2.0, 2.1, 2.2

Оцените этот модуль
Рейтинг: 5 из 5   -   1 голосов
  • Opencart 2.0
  • Opencart 2.1 и ocStore 2.1
  • Opencart 2.2

Нужен этот модуль для Opencart 3.0 ?

1. Скачайте и установите фикс Localcopy
2. Обновите модификации в админке
3. Загрузите модуль наново

Ошибка 500 после установки модуля означает, что случилась какая-то критическая ошибка в php.

Для определение проблемы можно:
1. Открыть файл logs/error.log на вашем сервере. В конце этого файла будут все последние критические ошибки.
2. Открыть в админке Инструменты > Логи ошибок - в этом месте отображаются ошибки, но не всегда.
3. Включить вывод ошибок php на экран - добавить следующий код в конец файла .htaccess:

php_value display_errors 1
php_value display_startup_errors 1
php_value error_reporting E_ALL

Возможные причины:

1. Если вы раньше не загружали модули в архиве через админку - вам нужно установить бесплатную модификацию localcopy.ocmod.xml согласно инструкции и после этого переустановить модуль

2. Возможно  в устанавливаемого модуля нет собственной страницы настроек и соответственно его не будет в списке Модулей

Два варианта решения:

1. Если при установке модуля из админки вылетает эта ошибка - вам нужно установить бесплатную FTP QuickFix модификацию localcopy.ocmod.xml. Она установиться без проблем через тот же установщик дополнений, только после установки не забудьте обновить модификации и затем можете приступать к установке любых модулей на Opencart 2.

2. Также решить эту ошибку можно по другому: прописать доступы к FTP в админке Система > Настройки > Магазин > вкладка FTP.

Если вы видите сообщение "Доступ запрещен!  У Вас нет прав для доступа к этой странице. Если она Вам нужна, обратитесь к администратору." -  нужно дать права администраторам на управление модулем или страницей.

Решение: в админке Opencart 2 переходим в Система > Пользователи > Группы пользователей > Администраторы и здесь нажимаем "Выделить все" ниже обоих блоков, затем Сохранить.

Еще одной причиной появления этой ошибки может быть не правильная установка модуля - файлы не загрузились на свои места. Загрузите файлы модуля вручную на сервер или установите фикс localcopy и переустановите модуль.

Решение: в админке Opencart 2 переходим в Система > Пользователи > Группы пользователей > Администраторы и здесь нажимаем "Выделить все" ниже обоих блоков, затем Сохранить.

Если модуль - это один XML файл,  то его расширение должно быть .ocmod.xml

Если модуль - это ocmod.zip архив, то его не нужно распаковывать, а устанавливать как есть. В таком архиве обязательно должна быть папка upload (может быть пустой), а также могут быть файлы модификаций: install.xml, install.php, install.sql. Никаких других файлов в корне архива быть не должно.

Читайте подробнее как устанавливать модули в Opencart 2

Эта ошибка означает, что в загружаемом архиве отсутсвует папка upload. Даже если у модуля нет файлов, кроме модификаций - эта папка должна присутствовать в архиве модуля .ocmod.zip, тогда она должна оставаться пустой.

Эта ошибка означает, что вы пытаетесь установить модификатор, который уже установлен или, возможно, у какого-то вашего модуля такой же ID.

Для решения этой ошибки вам нужно перед установкой удалить старую версию модификации в разделе Модули > Модификации.

Если такого модуля у вас нет, но совпадает ID, тогда нужно поменять значение параметра <code> в устанавливаемом модификаторе XML, сделать этот параметр уникальным дописав несколько символов.

Эта ошибка означает, что вы пытаетесь установить слишком объемный xml-модификатор.

Количество символов в ocmod.xml файле не должно превышать 65535.

Для решения ошибки нужно разбить xml-файл модификации на несколько частей, главное - не забыть задавать каждой уникальное значение в <code>, можно добавлять к текущему значению цифры 1,2,3... как идентификаторы части.

Еще одним способом решения есть изменения типа в поля, где храняться модификации, в таблице 'oc_modification' базы данных. Нужно выполнить следующий SQL-запрос:
ALTER TABLE oc_modification CHANGE xml xml MEDIUMTEXT CHARACTER SET utf8 COLLATE utf8_general_ci NOT NULL ;

Похоже, вы установили на Opencart 2.3.x.x модуль для более старых версий этой системы, то есть не совместимый модуль. Нужно удалить все файлы этого модуля, иначе ошибка не исчезнет.

Для удаления файлов модулей из админкм в один клик можно использовать модуль 

Также данная ошибка может возникать, если скрипт обращается к несуществующей таблице в базе данных. То есть, таблица модуля не создалась при установке. Читайте инструкцию по установке и переустановите модуль.

Если модуль не реагирует на ваши действия, будь-то нажатие на кнопку или загрузка карты или выбор даты или на любое другое действие которое есть в функционале модуля - скорее всего произошел конфликт в JS-скриптах.

Нажмите F12 на проблемной странице в браузере - откроется панель вебмастера, где на вкладке Console можно увидеть конфликты в скриптах, если они есть. Данное действие доступно в браузерах Chrome, Opera, Firefox.


Это раздел отзывов, комментариев и вопросов!
Решением проблем занимается техподдержка

Админка / Бек-энд

Бесплатно


или
Оформить VIP-подписку на все файлы
Подробнее о VIP-подписке

  • Cовместимость протестирована
  • Формат OCMOD
  • Открытый код
  • Нет привязки к домену
  • Нет вирусов и жучков

Про Opencart 2:

Купить VIP подписку на модули и шаблоны Opencart 2.x

Смотрите также:

Модуль Родительские опции Opencart 2

Модуль Родительские опции Opencart 2

Модуль Родительские / Связанные / Зависимые опции Opencart 2Проверено на OpenCart 2.0, 2.1, 2.2, 2.3..

Бесплатно

Менеджеры для магазинов на Opencart 2

Менеджеры для магазинов на Opencart 2

Менеджеры для магазинов на Opencart 2 - модуль для назначения пользователей администраторами мульти-..

Бесплатно

Русский язык Opencart 2.x Автоустановка Ocmod

Русский язык Opencart 2.x Автоустановка Ocmod

Модуль Русский язык Opencart 2.x Автоустановка Ocmod-модификация. Устанавливаеться полностью автомат..

Бесплатно

Список категорий с чекбоксами в форме товара на Opencart 2

Список категорий с чекбоксами в форме товара на Opencart 2

Модуль заменяет стандартную форму выбора категории товара с автозаполнением на список категорий с че..

Цена: 199 руб.

Модуль Custom PHP-код для Opencart 2

Модуль Custom PHP-код для Opencart 2

Модуль PHP-код для Opencart 2 позволяет вставить custom php код в позиции сайта. Вы можете вводить п..

Цена: 199 руб.

Модуль Менеджер рассылки для Opencart 2

Модуль Менеджер рассылки для Opencart 2

Менеджер рассылки - модуль для управления подпиской и рассылкой, он поможет вам упростить процесс сб..

Цена: 399 руб.

Необязательное поле "Модель" на Opencart 2

Необязательное поле "Модель" на Opencart 2

Простая модификация которая сделает поле "Модель" необязательным для заполнения.Иногда это поле..

Бесплатно

Фильтр товаров по категориям в админке Opencart 2

Фильтр товаров по категориям в админке Opencart 2

Модификация, которая добавляет фильтр по категории в список товаров в админке Opencart 2. Также доба..

Бесплатно