Вход на сайт

Регистрация на сайте автоматическая при оформлении первого заказа

Карта представительств на Opencart 2 - это модуль, позволяющий выводить Яндекс-карту с нанесенными точками ваших магазинов, офисов, реселлеров, представительств.

Функции модуля:
- возможность автоматически задавать координаты магазинов в админке по карте: перемещая маркер или вводя адрес точки
- вывод меток ваших представительств или точек самовывоза на интерактивной карте, метки активные, при клике метку всплывает контактная информация об этом магазине/офисе: адрес, телефоны, время работы
- кластеризация меток на карте (объединение меток в масивы)
- поиск по регионам на карте Яндекс
- асинхронная загрузка скриптов карты, не нагружает страницу.

Установка модуля Карта Yandex:
1. Установить модуль из админки (ocmod-архив) или распаковать и загрузить файлы в папку с сайтом.
2. Обновить модификации в админке
3. Добавить ваши магазины или офисы в Система > Локализация > Местонахождения ( или Торговые точки, Магазины)
4. Перейти в Дополнения > Модули, включить модуль Карта представительств.
5. Редактировать модуль и установить статус "Включено"
6. Вывести модуль на сайт в разделе Дизайн > Макеты

Модуль работает на Opencart 2.0, 2.1, 2.2, 2.3

Изменения:
24.09.2017 - добавлена совместимость с Opencart 2.3
24.11.2018 - решены ошибки с картинками в версии 2.3
25.09.2019 - решена проблема с отображением карты в админке на https-протоколе

Оцените этот модуль
Рейтинг: 5 из 5   -   1 голосов
  • Opencart 2.0
  • Opencart 2.1 и ocStore 2.1
  • Opencart 2.2
  • Opencart 2.3 и ocStore 2.3

Нужен этот модуль для Opencart 3.0 ?

1. Скачайте и установите фикс Localcopy
2. Обновите модификации в админке
3. Загрузите модуль наново

Ошибка 500 после установки модуля означает, что случилась какая-то критическая ошибка в php.

Для определение проблемы можно:
1. Открыть файл logs/error.log на вашем сервере. В конце этого файла будут все последние критические ошибки.
2. Открыть в админке Инструменты > Логи ошибок - в этом месте отображаются ошибки, но не всегда.
3. Включить вывод ошибок php на экран - добавить следующий код в конец файла .htaccess:

php_value display_errors 1
php_value display_startup_errors 1
php_value error_reporting E_ALL

Возможные причины:

1. Если вы раньше не загружали модули в архиве через админку - вам нужно установить бесплатную модификацию localcopy.ocmod.xml согласно инструкции и после этого переустановить модуль

2. Возможно  в устанавливаемого модуля нет собственной страницы настроек и соответственно его не будет в списке Модулей

Два варианта решения:

1. Если при установке модуля из админки вылетает эта ошибка - вам нужно установить бесплатную FTP QuickFix модификацию localcopy.ocmod.xml. Она установиться без проблем через тот же установщик дополнений, только после установки не забудьте обновить модификации и затем можете приступать к установке любых модулей на Opencart 2.

2. Также решить эту ошибку можно по другому: прописать доступы к FTP в админке Система > Настройки > Магазин > вкладка FTP.

Если вы видите сообщение "Доступ запрещен!  У Вас нет прав для доступа к этой странице. Если она Вам нужна, обратитесь к администратору." -  нужно дать права администраторам на управление модулем или страницей.

Решение: в админке Opencart 2 переходим в Система > Пользователи > Группы пользователей > Администраторы и здесь нажимаем "Выделить все" ниже обоих блоков, затем Сохранить.

Еще одной причиной появления этой ошибки может быть не правильная установка модуля - файлы не загрузились на свои места. Загрузите файлы модуля вручную на сервер или установите фикс localcopy и переустановите модуль.

Решение: в админке Opencart 2 переходим в Система > Пользователи > Группы пользователей > Администраторы и здесь нажимаем "Выделить все" ниже обоих блоков, затем Сохранить.

Если модуль - это один XML файл,  то его расширение должно быть .ocmod.xml

Если модуль - это ocmod.zip архив, то его не нужно распаковывать, а устанавливать как есть. В таком архиве обязательно должна быть папка upload (может быть пустой), а также могут быть файлы модификаций: install.xml, install.php, install.sql. Никаких других файлов в корне архива быть не должно.

Читайте подробнее как устанавливать модули в Opencart 2

Эта ошибка означает, что в загружаемом архиве отсутсвует папка upload. Даже если у модуля нет файлов, кроме модификаций - эта папка должна присутствовать в архиве модуля .ocmod.zip, тогда она должна оставаться пустой.

Эта ошибка означает, что вы пытаетесь установить модификатор, который уже установлен или, возможно, у какого-то вашего модуля такой же ID.

Для решения этой ошибки вам нужно перед установкой удалить старую версию модификации в разделе Модули > Модификации.

Если такого модуля у вас нет, но совпадает ID, тогда нужно поменять значение параметра <code> в устанавливаемом модификаторе XML, сделать этот параметр уникальным дописав несколько символов.

Эта ошибка означает, что вы пытаетесь установить слишком объемный xml-модификатор.

Количество символов в ocmod.xml файле не должно превышать 65535.

Для решения ошибки нужно разбить xml-файл модификации на несколько частей, главное - не забыть задавать каждой уникальное значение в <code>, можно добавлять к текущему значению цифры 1,2,3... как идентификаторы части.

Еще одним способом решения есть изменения типа в поля, где храняться модификации, в таблице 'oc_modification' базы данных. Нужно выполнить следующий SQL-запрос:
ALTER TABLE oc_modification CHANGE xml xml MEDIUMTEXT CHARACTER SET utf8 COLLATE utf8_general_ci NOT NULL ;

Похоже, вы установили на Opencart 2.3.x.x модуль для более старых версий этой системы, то есть не совместимый модуль. Нужно удалить все файлы этого модуля, иначе ошибка не исчезнет.

Для удаления файлов модулей из админкм в один клик можно использовать модуль 

Также данная ошибка может возникать, если скрипт обращается к несуществующей таблице в базе данных. То есть, таблица модуля не создалась при установке. Читайте инструкцию по установке и переустановите модуль.

Если модуль не реагирует на ваши действия, будь-то нажатие на кнопку или загрузка карты или выбор даты или на любое другое действие которое есть в функционале модуля - скорее всего произошел конфликт в JS-скриптах.

Нажмите F12 на проблемной странице в браузере - откроется панель вебмастера, где на вкладке Console можно увидеть конфликты в скриптах, если они есть. Данное действие доступно в браузерах Chrome, Opera, Firefox.

Яндекс начал требовать ключ API для работы карты.
То есть вам нужно:
1. Получить ключ API здесь https://developer.tech.yandex.ru/services/
При подключении к API для получения ключа вам нужно выбрать вариант "JavaScript API и HTTP Геокодер", так можно бесплатно получить ключ для работы карты на сайте. После заполнения формы вы получите ключ, который нужно подставить в строку ниже (вместо фразы "КЛЮЧ"):
<script src="https://api-maps.yandex.ru/2.1/?apikey=КЛЮЧ&lang=ru_RU" type="text/javascript"></script>
и вставить эту строку в шапку сайта (файл catalog/view/theme/шаблон/template/common/header.tpl) перед закрывающим тегом </head>
3. Открыть файл catalog\view\theme\default\template\extension\module\locations.tpl
и удалить там строку
<script src="https://api-maps.yandex.ru/2.1/?lang=ru_RU" type="text/javascript"></script>
4. Обновить кэш модификаторов в админке.  

По умолчанию длина текста в поле Адрес должна быть не больше 128 cимволов, у вас больше - поэтому ошибка. Но в тексте перевода ошибки указано 256, что тоже ошибка.

Можно увеличить длину текста в этом поле, откройте файл admin\controller\localisation\location.php
найдите там строку
if ((utf8_strlen($this->request->post['address']) < 3) || (utf8_strlen($this->request->post['address']) > 128)) {
и замените здесь 128 на любое большое число, типа 999999
Сохраните файл и обновите кэш модификаторов в админке.


Это раздел отзывов, комментариев и вопросов!
Решением проблем занимается техподдержка

Внешний вид
  • Цена: 199 руб.

- с помощьюВарианты оплаты заказа
или
Оформить VIP-подписку на все файлы
Подробнее о VIP-подписке

  • Cовместимость протестирована
  • Формат OCMOD
  • Открытый код
  • Нет привязки к домену
  • Нет вирусов и жучков
  • Техподдержка

Про Opencart 2:

Купить VIP подписку на модули и шаблоны Opencart 2.x

Смотрите также:

Модуль Облако тегов для Opencart 2.x

Модуль Облако тегов для Opencart 2.x

Модуль для создания Облака тегов товаров на Opencart 2.x. Модуль можно вывести в позиции на страницы..

Бесплатно

Картинки подкатегорий на странице категории Opencart 2.x

Картинки подкатегорий на странице категории Opencart 2.x

Модуль для создания плитки подкатегорий с картинками на замену стандартным ссылкам на странице катег..

Бесплатно

Модуль Производители в категории товаров Opencart 2.x

Модуль Производители в категории товаров Opencart 2.x

Модификация для Opencart 2.x добавляет на страницу категории товаров ссылки на производителей, товар..

Цена: 299 руб.

Модуль Цена товара в разных валютах Opencart 2.x

Модуль Цена товара в разных валютах Opencart 2.x

Модуль для автоматического рассчета согласно курсу и вывода цены товара во всех доступных валютах на..

Цена: 199 руб.

Количество просмотров товара Opencart 2

Количество просмотров товара Opencart 2

Модуль Количество просмотров товара Opencart 2 выводит счетчик просмотров в карточке товара.Мод..

Бесплатно

Модуль Всплывающие уведомления для Opencart 2

Модуль Всплывающие уведомления для Opencart 2

Модуль Всплывающие уведомления для Opencart 2 - выводит на экран pop-up окна с сообщениями для польз..

Цена: 299 руб.

Фильтр по цене (слайдер) для Opencart 2

Фильтр по цене (слайдер) для Opencart 2

Фильтр по цене в виде слайдера для Opencart 2 - это ajax-фильтр товаров, который можно вывести в кат..

Бесплатно

Модуль Единицы измерения для цены товара Opencart 2.x

Модуль Единицы измерения для цены товара Opencart 2.x

Модуль позволит создавать собственные единицы измерения для цен товаров в Opencart 2.x. Также в моду..

Цена: 399 руб.